Here’s some more information about the IE Zero-Day vulnerability mentioned yesterday in IT-Pros:

At any rate, until it’s patched, we should probably encourage our colleagues NOT to use IE–plenty of other browsers (Firefox, Chrome, Opera, etc etc) not affected.

Folks with the wherewithal and knowledge to install EMET 4.1 can lessen the impact of the vulnerability. Here’s the direct link to info about EMET: